下你所需,载你所想!
IT技术源码资料下载网站

取指定文本行内容

:23.821KB

:1:2021-01-12 23:04:10

部分简介

.子程序 文本_取文本所在行, 整数型, 公开, 查找某段字或关键中在文本中的哪一行出现,成功返回行数,失败返回0
.参数 源文本, 文本型
.参数 欲查找的文本, 文本型
.参数 是否区分大小写, 逻辑型, 可空
.局部变量 局_文本, 文本型, , "0"
.局部变量 局_计次, 整数型

局_文本 = 分割文本 (源文本, #换行符, )
.计次循环首 (取数组成员数 (局_文本), 局_计次)
.如果真 (寻找文本 (局_文本 [局_计次], 欲查找的文本, , 取反 (是否区分大小写)) ≠ -1)
返回 (局_计次)
.如果真结束

.计次循环尾 ()

相关阅读

最近更新