下你所需,载你所想!
IT技术源码资料下载网站

URL编码模块

:1.755KB

:1:2021-05-23 06:17:23

部分简介

.子程序 UTF8编码转换, 文本型, 公开, 将一个UTF8编码的文本转换为URL编码,返回一个URL编码
.参数 文本, 文本型, , 需要转换为URL编码的UTF8编码的文本
.局部变量 URL码, 文本型
.局部变量 n, 整数型
.局部变量 UTF8文本, 字节集

UTF8文本 = 编码转换 (到字节集 (文本), #编码_GBK, #编码_UTF_8, )
.计次循环首 (取字节集长度 (UTF8文本), n)
URL码 = URL码 + “%” + 取十六进制文本 (UTF8文本 [n])
.计次循环尾 ()URL编码模块例子。

相关阅读

最近更新