下你所需,载你所想!
IT技术源码资料下载网站

自定义树形框文本颜色,失去焦点选中项保持高亮

:4.836KB

:1:2021-05-25 11:01:12

部分简介

.如果真 (子项目 = 0) ' 取子取不到,就取兄弟
子项目 = SendMessage (树型框句柄, #TVM_GETNEXTITEM, #TVGN_NEXT, 数值) ' 取子的兄弟
' 找到了兄弟就直接到循环尾,否则进入下面的循环找父项目
.判断循环首 (子项目 = 0)
父项目 = SendMessage (树型框句柄, #TVM_GETNEXTITEM, #TVGN_PARENT, 数值) ' 退回上一级
.如果真 (父项目 = 0)
完成 = 真
跳出循环 ()
.如果真结束
数值 = 父项目
子项目 = SendMessage (树型框句柄, #TVM_GETNEXTITEM, #TVGN_NEXT, 父项目) ' 取父的兄弟
.判断循环尾 ()
.如果真结束
.如果真 (完成)
自定义树形框文本颜色,失去焦点选中项保持高亮例子。

相关阅读

最近更新