下你所需,载你所想!
IT技术源码资料下载网站

配置项读写原理,文本操作用

:2.851KB

:1:2021-05-25 11:06:01

部分简介

临时节 = “[” + 临时节名 + “]” ' 记录下每一个节名,方便后面的写到文件
配置内容 = 取文本右边 (节数组 [i], 取文本长度 (节数组 [i]) - 寻找到位置 - 2)
配置项组 = 分割文本 (配置内容, #换行符, )
.计次循环首 (取数组成员数 (配置项组), j)
寻找到位置 = 寻找文本 (配置项组 [j], “=”, , 假)
临时配置项名 = 取文本左边 (配置项组 [j], 寻找到位置 - 1)
.判断开始 (临时配置项名 = 配置项名)
.如果真 (欲写入的值 ≠ “”)
配置项组 [j] = 临时配置项名 + “=” + 欲写入的值
临时节 = 临时节 + #换行符 + 配置项组 [j] ' 当欲写入的值=空 的时候就不写也就是删除该项
.如果真结束
是否改变 = 真
.默认
临时节 = 临时节 + #换行符 + 配置项组 [j]
.判断结束

.计次循环尾 ()
配置项读写原理,文本操作用例子。

相关阅读

最近更新