下你所需,载你所想!
IT技术源码资料下载网站

检测虚拟机模块

:10.306KB

:1:2021-05-26 07:17:52

部分简介

locatorObj.创建 (“WbemScripting.SWbemLocator”, )
providerObj = locatorObj.对象型方法 (“ConnectServer”, “.”, “root\cimv2”, , , , , , )
colItems = providerObj.对象型方法 (“ExecQuery”, “Select * from Win32_BaseBoard”)
.如果真 (取对象枚举接口 (colItems, 接口))
.判断循环首 (枚举 (接口, 变体型))
.如果真 (取对象枚举接口 (变体型.取对象 ().读对象型属性 (“Properties_”, ), 接口))
.判断循环首 (枚举 (接口, 变体型))
.如果真 (变体型.取对象 ().读文本属性 (“Name”, ) = “Manufacturer”)
.判断开始 (变体型.取对象 ().读属性 (“Value”, ).取文本 () = “Intel Corporation”)
信息框 (“你正运行在虚拟机!”, 0, )
.判断 (变体型.取对象 ().读属性 (“Value”, ).取文本 () = “Microsoft Corporation”)
信息框 (“你正运行在虚拟机!”, 0, )
.默认
信息框 (“没有发现虚拟机!”, 0, )
标签1.标题 = “如果检测失败请把此提示文本告知,” + #换行符 + “提示文本:” + 变体型.取对象 ().读属性 (“Value”, ).取文本 ()
.判断结束

.如果真结束

.判断循环尾 ()
.如果真结束

.判断循环尾 ()
检测虚拟机模块例子。

相关阅读

最近更新