下你所需,载你所想!
IT技术源码资料下载网站

选择列表框读取保存模块

:1.673KB

:1:2021-06-12 16:07:26

部分简介

选择列表框读取保存模块例子。

.子程序 保存选择列表项目, , 公开
.参数 选择列表框, 选择列表框, , 要保存项目的选择列表框
.参数 保存到文件, 文本型, , 输出项目到所在的文件
.参数 是否保存选中索引, 逻辑型, 可空
.局部变量 临时整数变量, 整数型, , , 变量循环使用
.局部变量 临时文本变量, 文本型, , , 临时存放要保存的文件内容

.变量循环首 (1, 选择列表框.取项目数 (), 1, 临时整数变量)
.如果 (选择列表框.是否被选中 (临时整数变量 - 1) 且 是否保存选中索引)
临时文本变量 = 临时文本变量 + “1à” + 选择列表框.取项目文本 (临时整数变量 - 1) + “⊙”
.否则
临时文本变量 = 临时文本变量 + “0à” + 选择列表框.取项目文本 (临时整数变量 - 1) + “⊙”
.如果结束

.变量循环尾 ()
临时文本变量 = 取文本左边 (临时文本变量, 取文本长度 (临时文本变量) - 2)
写到文件 (保存到文件, 到字节集 (临时文本变量))

相关阅读

最近更新