下你所需,载你所想!
IT技术源码资料下载网站

汇编取通用指针

:1.18KB

:1:2021-08-31 13:48:19

部分简介

汇编取通用指针

置入代码 ({ 139, 69, 8 }) ' mov eax [ebp+8]
.如果真 (类型 = 1)
置入代码 ({ 201, 194, 4, 0 })
' leave
' retn 4
.如果真结束
.如果真 (类型 = 2)
置入代码 ({ 139, 0, 201, 194, 4, 0 })
' mov eax,[eax]
' leave
' retn 4
.如果真结束
.如果真 (类型 = 3)
置入代码 ({ 139, 0, 133, 192, 15, 132, 3, 0, 0, 0, 131, 192, 8, 201, 194, 4, 0 })
' mov eax,[eax]
' test eax,eax
' je label1
' add eax,8
' label1:
' leave
' retn 4
.如果真结束
返回 (0)

相关阅读

最近更新