新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

屏蔽程序信息框补丁源代码

作者:清柠 人气: 来源:易语言 2019-10-02 19:23:53

屏蔽程序信息框补丁源代码

hProcess = OpenProcess (2035711, 0, 进程ID)
hModule = LoadLibrary (“user32.dll”)
.如果真 (hModule = 0)
返回 (假)
.如果真结束
FARPROC = GetProcAddress (hModule, “MessageBoxA”)
.如果真 (FARPROC = 0)
返回 (假)
.如果真结束

.如果真 (VirtualProtectEx (hProcess, FARPROC, 4, 64, OldProtect) = 假)
返回 (假)
.如果真结束
.如果真 (WriteProcessMemory (hProcess, FARPROC, { 194, 16, 0, 144 }, 4, NumberOfBytesWritten) = 假)
返回 (假)
.如果真结束
.如果真 (NumberOfBytesWritten ≠ 4)
返回 (假)
.如果真结束
VirtualProtectEx (hProcess, FARPROC, 4, OldProtect, 0)
FARPROC = GetProcAddress (hModule, “MessageBoxW”)
.如果真 (FARPROC = 0)
返回 (假)
.如果真结束

.如果真 (VirtualProtectEx (hProcess, FARPROC, 4, 64, OldProtect) = 假)
返回 (假)
.如果真结束
.如果真 (WriteProcessMemory (hProcess, FARPROC, { 194, 16, 0, 144 }, 4, NumberOfBytesWritten) = 假)
返回 (假)
.如果真结束
.如果真 (NumberOfBytesWritten ≠ 4)
返回 (假)
.如果真结束
VirtualProtectEx (hProcess, FARPROC, 4, OldProtect, 0)
返回 (真)

官方微信二维码 新锐官方微信公众号