新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

自动爬虫批量下载昵图网图片源码

作者:清柠 人气: 来源:易语言 2019-10-10 22:06:16

自动爬虫批量下载昵图网图片源码

网页返回 = 网页访问u (“?q=图片&page=” + 到文本 (网页))
正则.创建 (#常量2, 网页返回, 假, 真)
.计次循环首 (正则.取匹配数量 (), 计次)
url地址 = 正则.取子匹配文本 (计次, 1)
url数组 = 分割文本 (url地址, #右引号, )
A = 取数组成员数 (url数组)
连接 = url数组 [A]
i = 取文本长度 (连接)
i = i - 2
url链接 = 取文本左边 (连接, i) + “pg”
超级列表框1.插入表项 (0, , , , , )
超级列表框1.置标题 (0, 0, url链接)
图片 = HTTP读文件 (url链接)
写到文件 (“G:\爬虫图片1\” + 到文本 (计次) + 到文本 (取随机数 (, )) + “.jpg”, 图片)
图片框1.图片 = 图片
标题 = “已下载:” + 到文本 (计次)
.如果真 (正则.取匹配数量 () = 计次)
网页 = 网页 + 1
.如果真结束
调试输出 (网页)
.计次循环尾 ()

官方微信二维码 新锐官方微信公众号