新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

基于迅雷看看APlayer内核开发的视频播放器源码

作者:清柠 人气: 来源:易语言 2019-10-05 18:50:56

基于迅雷看看APlayer内核开发的视频播放器源码

会美工的自己ps图片,把皮肤改了,就完全不一样了!

匹配连续剧的原理是,先搜索同目录下所有视频文件,取文件名,然后根据选择文件的文件名写创建一个正则表达式,然后匹配,再排序!

.如果真 (列表窗口.播放队列列表框.取标题 (cx, 1) ≠ “”)
.' 如果真 (取文本左边 (列表窗口.播放队列列表框.取标题 (cx, 1), 倒找文本 (列表窗口.播放队列列表框.取标题 (cx, 1), “\”, , 假) - 1) ≠ “”)
' 写配置项 (取运行目录 () + “\config\user.ini”, “Volume”, “路径”, 取文本左边 (列表窗口.播放队列列表框.取标题 (cx, 1), 倒找文本 (列表窗口.播放队列列表框.取标题 (cx, 1), “\”, , 假) - 1))
.如果真结束
.如果真 (Aplayer.获取播放状态 () ≠ 0)
Aplayer.关闭 ()
' 程序_延时 (1)
关闭事件 ()
' 程序_延时 (1)
处理事件 ()
.如果真结束
Aplayer.Set设置 (2401, “1”)
.如果 (Aplayer.打开 (列表窗口.播放队列列表框.取标题 (cx, 1)))
适应视频尺寸 = 真
.如果真 (设置窗口.选择框_清空历史.选中 = 真)
列表窗口.历史记录列表框.全部删除 ()
.如果真结束
正在播放bx = cx
列表窗口.播放队列列表框.现行选中项 = cx
透明标签2.标题 = 列表窗口.播放队列列表框.取标题 (cx, 0)
本地字幕 (列表窗口.播放队列列表框.取标题 (cx, 1))
添加提示文本 (“开始缓冲在线视频”, 10, 10)
.否则
添加提示文本 (“打开 ” + 列表窗口.播放队列列表框.取标题 (cx, 0) + “ 失败”, 10, 10)
.如果结束
Aplayer.设置播放位置 (0)

官方微信二维码 新锐官方微信公众号