新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

方舟生存进化服务器自助机器人

作者:清柠 人气: 来源:易语言 2019-12-20 13:10:56

方舟生存进化服务器自助机器人

.如果真 (窗口3.客户1.连接 (读配置项 (应用目录 + “\YMARK.ini”, “服务器信息”, “PVEIP”, ), 到整数 (读配置项 (应用目录 + “\YMARK.ini”, “服务器信息”, “PVE端口”, ))) = 真)
延迟 (500)
Rcon发送 (读配置项 (应用目录 + “\YMARK.ini”, “服务器信息”, “PVE密码”, ), “9500”, 3, 窗口3.客户1)
延迟 (500)
Rcon发送 (编码_gb2312到utf8 (“AddPoints” + “ ” + steamID + “ ” + 到文本 (奖励金额)), “9500”, 2, 窗口3.客户1)
延迟 (500)
窗口3.客户1.断开连接 ()
写到文件 (日志名, 读入文件 (日志名) + 到字节集 (#换行符 + QQ号 + “-----” + “时间:” + 到文本 (取现行时间 ())))
CQ.发送群消息 (群号, CQ.CQ码_At (qq) + “恭喜你签到成功,本次签到获得了:” + 到文本 (奖励金额) + #换行符 + “你累计签到:” + 到文本 (到整数 (签到次数) + 1) + “次” + #换行符 + “你通过签到累计获得了:” + 到文本 (到整数 (累计奖励) + 奖励金额) + “的在线金币奖励” + #换行符 + “明天记得在来哦!”)
数据库.执行SQL语句 (“UPDATE QUN set QDCS= '” + 到文本 (到整数 (签到次数) + 1) + “'where id= '” + 数据ID + “'”)
数据库.执行SQL语句 (“UPDATE QUN set LJJL= '” + 到文本 (到整数 (累计奖励) + 奖励金额) + “'where id= '” + 数据ID + “'”)
返回 ()
.如果真结束
CQ.发送群消息 (群号, CQ.CQ码_At (qq) + “链接服务器RCON控制台失败” + #换行符 + “请联系服核对服务器信息”)
.否则
.如果真 (窗口3.客户1.连接 (读配置项 (应用目录 + “\YMARK.ini”, “服务器信息”, “PVPIP”, ), 到整数 (读配置项 (应用目录 + “\YMARK.ini”, “服务器信息”, “PVP端口”, ))) = 真)
延迟 (500)
Rcon发送 (读配置项 (应用目录 + “\YMARK.ini”, “服务器信息”, “PVP密码”, ), “9500”, 3, 窗口3.客户1)
延迟 (500)
Rcon发送 (编码_gb2312到utf8 (“AddPoints” + “ ” + steamID + “ ” + 到文本 (奖励金额)), “9500”, 2, 窗口3.客户1)
延迟 (500)
.如果真 (到文本 (到整数 (签到次数) + 1) = 签到多次)
CQ.发送群消息 (群号, CQ.CQ码_At (qq) + “你已经签到了” + 到文本 (到整数 (签到次数) + 1) + “次。获得了累计签到” + 签到多次 + “次的签到累计奖励” + 签到多次奖励 + #换行符 + “只要有梦想坚持就会得到回报”)
延迟 (500)
Rcon发送 (编码_gb2312到utf8 (“AddPoints” + “ ” + steamID + “ ” + 到文本 (签到多次奖励)), “9500”, 2, 窗口3.客户1)
数据库.执行SQL语句 (“UPDATE QUN set LJJL= '” + 到文本 (到整数 (累计奖励) + 到整数 (签到多次奖励)) + “'where id= '” + 数据ID + “'”)
.如果真结束
窗口3.客户1.断开连接 ()
写到文件 (日志名, 读入文件 (日志名) + 到字节集 (#换行符 + QQ号 + “-----” + “时间:” + 到文本 (取现行时间 ())))
CQ.发送群消息 (群号, CQ.CQ码_At (qq) + “恭喜你签到成功,本次签到获得了:” + 到文本 (奖励金额) + #换行符 + “你累计签到:” + 到文本 (到整数 (签到次数) + 1) + “次” + #换行符 + “你通过签到累计获得了:” + 到文本 (到整数 (累计奖励) + 奖励金额) + “的在线金币奖励” + #换行符 + “明天记得在来哦!”)
数据库.执行SQL语句 (“UPDATE QUN set QDCS= '” + 到文本 (到整数 (签到次数) + 1) + “'where id= '” + 数据ID + “'”)
数据库.执行SQL语句 (“UPDATE QUN set LJJL= '” + 到文本 (到整数 (累计奖励) + 奖励金额) + “'where id= '” + 数据ID + “'”)

官方微信二维码 新锐官方微信公众号