新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

拼多多全自动下单工具核心源码

作者:清柠 人气: 来源:易语言 2019-12-01 08:18:52

拼多多全自动下单工具核心源码

.子程序 方法_申请退货退款, 逻辑型, 公开
.参数 订单ID号, 文本型
.参数 退款类型, 文本型, , 95-其它 86-假冒品牌 83-卖家发错货 85-收到商品少件、破损或污渍 81-质量问题 278-颜色、款式、图案与描述不符 277-大小尺寸与商品描述不符 276-材质、面料与商品描述不符 87-不喜欢、效果不好 88-多拍、拍错、不想要
.参数 退款描述, 文本型
.参数 图片组, 文本型, 可空 数组
.局部变量 json, 类_json
.局部变量 下单金额, 文本型
.局部变量 联系电话, 文本型
.局部变量 index, 整数型
.局部变量 sdata, 文本型
方法_更新订单 (订单ID号, 假, , , , , 下单金额, , , , , 联系电话)
json.置属性 (“order_sn”, 订单ID号)
json.置属性数值 (“coupon_return_control_type”, 0)
json.置属性数值 (“after_sales_type”, 2)
json.置属性数值 (“user_ship_status”, 0)
json.置属性 (“user_phone”, 联系电话)
.如果 (取数组成员数 (图片组) ≤ 0)

.否则
    .计次循环首 (取数组成员数 (图片组), index)
        json.加成员 (图片组 [index], “images”, 真)
    .计次循环尾 ()
.如果结束

json.置属性数值 (“return_coupon_amount”, 0)
json.置属性数值 (“question_type”, 到数值 (退款类型))
json.置属性 (“question_desc”, 编码_URL编码 (退款描述, 真, 真))
json.置属性数值 (“part_as_type”, 1)
json.置属性数值 (“part_as_val”, 1)
json.置属性数值 (“refund_amount”, 到数值 (下单金额) × 100)  ' 退款金额
sdata = 拼多多方法_POST (“https://mobile.yangkeduo.com/proxy/api/create?pdduid=” + 集_PDDUID, json.取数据文本 (), “Content-Type: application/json;charset=UTF-8”)
.如果真 (json.解析 (sdata))
    .如果 (json.取通用属性 (“after_sales_id”) ≠ “”)
        返回 (真)
    .否则
        返回 (假)
    .如果结束
.如果真结束
返回 (假)

官方微信二维码 新锐官方微信公众号