下你所需,载你所想!
IT技术源码资料下载网站

创建进程载入DLL

:10.395KB

:1:2021-01-11 15:29:52

部分简介

创建进程载入DLL例子。
.子程序 内存_修改进程虚拟保护, 整数型, 公开, 修改成功返回原保护类型
.参数 进程句柄, 整数型
.参数 内存地址, 整数型, , 内存地址
.参数 保护长度, 整数型, 可空, 修改长度 默认为 5
.参数 保护类型, 整数型, 可空, PAGE_等 默认 PAGE_EXECUTE_WRITECOPY(允许任何操作)
.局部变量 原始保护类型, 整数型

.如果真 (是否为空 (保护长度) = 真)
保护长度 = 5
.如果真结束
.如果真 (是否为空 (保护类型) = 真)
保护类型 = #PAGE_EXECUTE_READWRITE
.如果真结束
VirtualProtectEx (进程句柄, 内存地址, 保护长度, 保护类型, 原始保护类型)
返回 (原始保护类型)

相关阅读

最近更新