下你所需,载你所想!
IT技术源码资料下载网站

全盘搜索指定文件工具

:123.413KB

:1:2021-01-13 18:17:23

部分简介

全盘搜索指定文件工具例子。
处理事件 () ' 给出机会以接收停止按钮事件,搜索时会占用程序的资源,使得延时处理其它事件,所要用:“处理事件()”。
.如果真 (取文本右边 (目录, 1) ≠ “\”) ' 判断当前目录的格式是否正确。如“C:”,这格式是不正确的,改为"C:\"。
目录 = 目录 + “\”
.如果真结束
文件名 = 寻找文件 (目录 + 要找的文件, )
标签1.标题 = “正在查找目录:” + 目录
.如果真 (文件名 ≠ “”)
找到文件 = 真
编辑框1.加入文本 (目录 + 文件名 + #换行符)

.如果真结束
文件名 = 寻找文件 (目录 + “*.*”, #子目录) ' 搜寻目录文件,包括子目录。
.判断循环首 (文件名 ≠ “”) ' 判断目录名是否有效,有效向下执行搜索。
.如果真 (取文本左边 (文件名, 1) ≠ “.”)
搜寻1 (目录 + 文件名, 要找的文件) ' 如果寻找到目录路径就搜继续搜索文件。
.如果真结束
文件名 = 寻找文件 (, #子目录)
.判断循环尾 ()

相关阅读

最近更新