下你所需,载你所想!
IT技术源码资料下载网站

易语言随机取大小写字母

:2.131KB

:1:2021-06-08 07:07:06

部分简介

.子程序 取随机大小写字母, 文本型
.参数 欲取出个数, 整数型, , 欲随机取出字母个数
.参数 字母大小写, 逻辑型, 可空, 真=大写 假=小写 留空=随机大小写
.局部变量 临时文本, 文本型
.局部变量 随机数, 整数型

置随机数种子 ()
.如果 (是否为空 (字母大小写) = 假)
.计次循环首 (欲取出个数, )
随机数 = 取随机数 (1, 26)
临时文本 = 临时文本 + 选择 (字母大小写 = 真, 到大写 (取文本中间 (#随机字母, 随机数, 1)), 到小写 (取文本中间 (#随机字母, 随机数, 1)))
.计次循环尾 ()
.否则
.计次循环首 (欲取出个数, )
随机数 = 取随机数 (1, 26)
临时文本 = 临时文本 + 选择 (随机数 % 2 = 1, 到大写 (取文本中间 (#随机字母, 随机数, 1)), 到小写 (取文本中间 (#随机字母, 随机数, 1)))
.计次循环尾 ()

相关阅读

最近更新