下你所需,载你所想!
IT技术源码资料下载网站

多因子排序

:1.854KB

:1:2021-09-05 12:19:44

部分简介

多因子排序

reg.创建 (“(\d+)楼(\d+)单元(\d+)”, , )
结果1 = reg.搜索 (a, )
结果2 = reg.搜索 (b, )
比较值 = 到整数 (结果1.取子匹配文本 (1)) - 到整数 (结果2.取子匹配文本 (1))
.如果 (比较值 > 0)
返回 (真)
.否则
.如果真 (比较值 = 0)
比较值 = 到整数 (结果1.取子匹配文本 (2)) - 到整数 (结果2.取子匹配文本 (2))
.如果 (比较值 > 0)
返回 (真)
.否则
.如果真 (比较值 = 0)
比较值 = 到整数 (结果1.取子匹配文本 (3)) - 到整数 (结果2.取子匹配文本 (3))
.如果真 (比较值 > 0)
返回 (真)

相关阅读

最近更新