新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

程序窗口淡入/淡出特效及贴边隐藏模块源码

作者:清柠 人气: 来源:易语言 2019-10-04 18:14:34

程序窗口淡入/淡出特效及贴边隐藏模块源码

设置窗口透明度 (窗口名称.取窗口句柄 (), 0)
窗口名称.可视 = 真
.计次循环首 (255, a)
设置窗口透明度 (窗口名称.取窗口句柄 (), a)
延迟 (10)
.计次循环尾 ()

.如果真 (窗口名称.左边 < 0 且 窗口名称.顶边 < 0)
窗口名称.移动 (0, 1, , )
.如果真结束
.如果真 (窗口名称.左边 ≥ 取屏幕宽度 () - 窗口名称.宽度 且 窗口名称.顶边 < 0)
窗口名称.移动 (取屏幕宽度 () - 窗口名称.宽度 - 1, 0, , )
.如果真结束

.如果真 (窗口名称.顶边 < 0 且 取鼠标水平位置 () > 窗口名称.左边 且 取鼠标水平位置 () < 窗口名称.左边 + 窗口名称.宽度 且 取鼠标垂直位置 () < 3)
窗口名称.顶边 = 0
.如果真结束
.如果真 (窗口名称.顶边 ≤ 0 且 窗口名称.左边 > 0 且 窗口名称.左边 < 取屏幕宽度 () - 窗口名称.宽度)
.如果真 (取鼠标水平位置 () < 窗口名称.左边 或 取鼠标水平位置 () > 窗口名称.左边 + 窗口名称.宽度 或 取鼠标垂直位置 () > 窗口名称.顶边 + 窗口名称.高度)
窗口名称.顶边 = 3 - 窗口名称.高度
.如果真结束

.如果真结束
.如果真 (窗口名称.左边 < 0 且 取鼠标垂直位置 () > 窗口名称.顶边 且 取鼠标垂直位置 () < 窗口名称.顶边 + 窗口名称.高度 且 取鼠标水平位置 () < 3)
窗口名称.左边 = 0
.如果真结束
.如果真 (窗口名称.左边 ≤ 0 且 窗口名称.顶边 > 0 且 窗口名称.顶边 < 取屏幕高度 () - 窗口名称.高度)
.如果真 (取鼠标垂直位置 () < 窗口名称.顶边 或 取鼠标垂直位置 () > 窗口名称.顶边 + 窗口名称.高度 或 取鼠标水平位置 () > 窗口名称.宽度)
窗口名称.左边 = 3 - 窗口名称.宽度
.如果真结束

.如果真结束
.如果真 (取鼠标水平位置 () > 取屏幕宽度 () - 3 且 取鼠标垂直位置 () > 窗口名称.顶边 且 取鼠标垂直位置 () < 窗口名称.顶边 + 窗口名称.高度)
窗口名称.左边 = 取屏幕宽度 () - 窗口名称.宽度
.如果真结束
.如果真 (窗口名称.左边 ≥ 取屏幕宽度 () - 窗口名称.宽度 且 窗口名称.顶边 > 0 且 窗口名称.顶边 < 取屏幕高度 () - 窗口名称.高度)
.如果真 (取鼠标垂直位置 () < 窗口名称.顶边 或 取鼠标垂直位置 () > 窗口名称.顶边 + 窗口名称.高度 或 取鼠标水平位置 () < 取屏幕宽度 () - 窗口名称.宽度)
窗口名称.左边 = 取屏幕宽度 () - 3

官方微信二维码 新锐官方微信公众号