下你所需,载你所想!
IT技术源码资料下载网站

快手滑块验证码人工自动识别源码

:149.979KB

:1:2019-12-19 08:35:44

部分简介

快手滑块验证码人工自动识别源码

.子程序 请求识别并返回答案, 文本型, 公开, 返回识别状态
.参数 apppkey, 文本型, , 网站注册后查看 user.cezhifu.cn
.参数 验证码地址, 文本型
.参数 答案, 文本型, 参考 可空, 用来接收验证码答案的
.参数 调试专用, 逻辑型, 可空, 真为输出调试,假为不输出调试
.局部变量 json, 类_json
.局部变量 验证码MD5, 文本型
.局部变量 临时内容, 文本型

临时内容 = 到文本 (编码转换 (POST (“home/index/index”, “appkey=” + apppkey + “&url=” + 编码_URL编码 (验证码地址, 真, 真)), #编码_UTF_8, #编码_GB2312, ))
.如果真 (调试专用)
调试输出 (临时内容)
.如果真结束
json.解析 (临时内容)
.如果真 (json.取通用属性 (“msg”) = “提交成功”)
验证码MD5 = json.取通用属性 (“md5s”)
.计次循环首 (60, )
临时内容 = 到文本 (编码转换 (POST (“home/index/check?appkey=” + apppkey + “&code=” + 验证码MD5), #编码_UTF_8, #编码_GB2312, ))
.如果真 (调试专用)
调试输出 (临时内容)
.如果真结束
json.解析 (临时内容)
.如果真 (json.取通用属性 (“msg”) = “识别成功” 或 json.取通用属性 (“msg”) ≠ “正在识别”)
答案 = json.取通用属性 (“result”)
跳出循环 ()
.如果真结束
延时 (2000)
.计次循环尾 ()
.如果真结束
返回 (json.取通用属性 (“msg”))

相关阅读

最近更新