新锐下载

下你所需,载你所想!
IT技术源码资料下载网站

音乐在线播放源码 可显示歌词/控制进度

作者:清柠 人气: 来源:易语言 2019-11-16 09:16:06

音乐在线播放源码 可显示歌词/控制进度

一款专门为音乐爱好者开发的功能超强、超酷的音乐播放、合成软件,有了它您可以在线免费音乐软件“开心听”,是一款集手机音乐播放、在线音乐播放。
听歌、练歌。
媒体播放1.停止 ()
临时_文本 = post.访问歌曲信息 (超级列表框1.取标题 (超级列表框1.现行选中项, 4), 超级列表框1.取标题 (超级列表框1.现行选中项, 3))
全局_歌词 = 编码_usc2到ansi (文本_取中间 (临时_文本, “lyrics” + #引号 + “:” + #引号, #引号, , , , ))
正则取歌词.创建 (#歌词匹配, 全局_歌词, 真, 真, 真, 真)
调试输出 (正则取歌词.取匹配数量 ())
.如果真 (正则取歌词.取匹配数量 () > 0)
重定义数组 (集_歌词_数组, 假, 正则取歌词.取匹配数量 (), 2)
.如果真结束
.计次循环首 (正则取歌词.取匹配数量 (), a)
集_歌词_数组 [I] [1] = 正则取歌词.取子匹配文本 (a, 1, )
集_歌词_数组 [I] [2] = 正则取歌词.取子匹配文本 (a, 2, )
.计次循环尾 ()
' 调试输出 (临时_文本)
临时_文本 = 文本_取中间 (临时_文本, “play_url” + #引号 + “:” + #引号, #引号, , , , )
临时_文本 = 文本_替换 (临时_文本, , , , “/”, “”, , , , , , , , )
媒体播放1.打开 (临时_文本)
媒体播放1.播放 (-1, )
滑块条1.最大位置 = 媒体播放1.取长度 () ÷ 1000
时钟1.时钟周期 = 100
时钟2.时钟周期 = 10
' 音乐_播放 (临时_文本, “1”)

分享:

官方微信二维码 新锐官方微信公众号